Due animazioni su una singola pagina web

Unisciti alla comunità di WebAnimator. Condividi le tue conoscenze e aiuta gli altri utenti.
Post Reply
Boncoddo
Posts: 3

Due animazioni su una singola pagina web

Post by Boncoddo » Mon Nov 20, 2017 6:13 pm

Salve a tutti, ho provato per la prima volta il vostro prodotto e devo dire che sono rimasto molto soddisfatto, riscontro però dei problemi esportando due progetti in HTML5, precisamente quando provo ad inserire le due animazioni esportate in un unica pagina web: si visualizza correttamente solo la prima animazione; sembra che ispezionando la pagina su Chrome si riscontrino dei problemi nel file "WA.js" relativo alla seconda animazione inserita, in realtà non si tratta di un vero e proprio errore ma di una stampa in console tramite un istruzione javascript, questo mi fa pensare che una situazione di questo genere era già stata preventivata ma non risolta. Grazie in anticipo per eventuali consigli.

P.S. Non ho intenzione di usare per nessun motivo iframe.

ICC
Posts: 486

Post by ICC » Tue Nov 21, 2017 2:29 pm

Buongiorno Boncoddo,

Ho contattato gli sviluppatori in merito e appena ho una risposta ti informo qui.

Grazie mille!

Boncoddo
Posts: 3

Post by Boncoddo » Thu Nov 23, 2017 7:09 pm

Faccio notare che i progetti devono avere la stessa "base", ad esempio io ho costruito un bottone "acquista" e l'ho salvato in un file di progetto con estensione ".wap", poi ho esportato il tutto in HTML5, dopodiché, ho riaperto il file cambiando solo il testo interno del bottone, poi ho ri-salvato il progetto con un altro nome ma sempre con estensione ".wap" e l'ho esportato nuovamente in HTML5, solo a questo punto ho inserito le due animazioni nella stessa pagina senza successo. Grazie ancora.

ICC
Posts: 486

Post by ICC » Fri Nov 24, 2017 1:00 pm

Buongiorno,

Le animazioni devono avere nomi diversi ad esempio Ani1 e Ani2 e devono essere esportate in cartelle diverse all'interno di una cartella.

Va creato un nuovo file html con il seguente codice nel caso fossero stati usati i nomi Ani1 e Ani2:

<!DOCTYPE html>
<html>
<head>
<title></title>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">

<script type='text/javascript' src='Ani1_resources/jquery-1.7.js'></script>
</head>
<body>

<div id="Ani1Stage" class="wascript">
<script type="text/javascript" charset="utf-8" src="Ani1_resources/WA_SCRIPT.js"></script>
</div>

<div id="Ani2Stage" class="wascript">
<script type="text/javascript" charset="utf-8" src="Ani2_resources/WA_SCRIPT.js"></script>
</div>

</body>
</html>

Ovviamente con altri nomi le parti
Ani1Stage
Ani1_resources
Ani2Stage
Ani2_resources
Vanno adattate di conseguenza.

Grazie mille!

Boncoddo
Posts: 3

Post by Boncoddo » Fri Nov 24, 2017 10:30 pm

Il mio problema (che ho poi risolto creando un nuovo progetto ex-novo e ricopiando gli elementi dal precedente) si verificava quando lavoravo partendo dalla stessa base di progetto... provate voi stessi: salvate un progetto con alcuni elementi inseriti nello stage, ri-salvate lo stesso progetto con un altro nome ma mantenendo gli stessi elementi, esportate entrambi i progetti in HTML5 e "uniteli" in una singola pagina così come descritto, noterete che funzionerà solo la prima animazione dichiarata; in pratica gli elementi esportati presenteranno lo stesso id nella pagina html (verificabile attraverso la funzione ispeziona di Google Chrome), di conseguenza, solo la prima animazione dichiarata sarà visualizzata, mentre la seconda no. A mio parere ad ogni salvataggio/esportazione il vostro software dovrebbe generare degli id casuali, si tratta di un bug nella parte che riguarda la serializzazione.

ICC
Posts: 486

Post by ICC » Tue Nov 28, 2017 1:05 pm

Buongiorno,

Essendo la stessa animazione gli ID sono gli stessi visto che non cambiano gli oggetti.
Conviene creare animazioni separate per non avere il problema degli stessi ID.
In ogni caso informerò gli sviluppatori.

Grazie mille!

Post Reply